Login is partially unavailable from east Asia states
Incident Report for eToro
Resolved
Issue has been resolved. Sorry for the inconvenience.
Posted Mar 19, 2020 - 10:07 GMT
Investigating
We are experiencing temporary technical difficulties. Please bear with us while we work on resolving the issue and stay tuned for further updates. We apologize for the inconvenience.
Posted Mar 19, 2020 - 08:49 GMT
This incident affected: Login & Registration (Login).