"Some customers may experience issues with eToro Money card transaction verification"
Incident Report for eToro
Resolved
Dear eToro Money Customers,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Nov 17, 2022 - 09:45 UTC
Monitoring
We have implemented a solution to resolve the issue, and will be monitoring it for the next 2 days to make sure it is successfully resolved.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Nov 15, 2022 - 16:36 UTC
Investigating
Please note that we currently have technical issues with one of the eToro Money services.
Our engineers are working hard to resolve this problem.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Nov 10, 2022 - 17:13 UTC
This incident affected: eToro Money (Cash Account).