User stats page is unavailable
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
During the time, customers who've tried to to access "Copy People", choose trader and see its stats, received an error.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Feb 24, 2021 - 17:21 UTC
Identified
The root cause of the issue has been identified and our developers are working to fix it.
Additional information will be provided as soon as possible.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Feb 24, 2021 - 17:13 UTC
Investigating
Please note that we currently have technical issues with User stats service.
During the time, customers who are trying to to access "Copy People", choose trader and see its stats, receive an error.
Our team is working hard to resolve the issue.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Feb 24, 2021 - 17:08 UTC
This incident affected: Platform (Stats).