User stats showing wrong information
Incident Report for eToro
Resolved
This incident has been resolved.
Posted May 14, 2020 - 15:17 UTC
Update
We've found the root cause for the issue and working to solve it.
We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible.
Posted May 14, 2020 - 13:48 UTC
Identified
We are experiencing a temporary issue with the user stats. We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible.
Posted May 14, 2020 - 12:43 UTC
This incident affected: eToro Platform (Daily Gain).