Customers might not be able to create accounts on eToro Money application

Incident Report for eToro

Resolved

Dear eToro Money Customers,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Jun 06, 2022 - 10:09 UTC

Identified

The root cause of the issue has been identified and our developers are working to fix it.
Additional information will be provided as soon as possible.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Jun 06, 2022 - 09:31 UTC
This incident affected: eToro Money (Cash Account, Debit Card).