Users may experience failures to open the Settings option and fill W-8ben form
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Nov 16, 2020 - 14:51 UTC
Identified
If you experience any failed attempts to open the Settings on your account please retry after a couple of minutes.
Our devs are working to resolve the issue

Sincerely,
The eToro Team
Posted Nov 16, 2020 - 14:22 UTC