Update
The scheduled maintenance has been completed.
Posted Oct 26, 2025 - 11:18 UTC
Completed
The scheduled maintenance has been completed.
Posted Oct 26, 2025 - 11:17 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 26, 2025 - 10:39 UTC
Scheduled
Quick correction regarding today’s (Sunday, October 26th) scheduled maintenance:
The maintenance window ended at 11:30 GMT, 1 hour later than initially communicated (08:30–10:30 GMT).
As a reminder, during the maintenance window:
Stop Loss and Take Profit continued to function normally.
Backtrader is available for closing open positions.
Access to the web and mobile platforms is temporarily unavailable.
We apologize for any inconvenience caused by the extended downtime and appreciate your understanding.
Thank you,
The eToro Team
Posted Oct 26, 2025 - 10:38 UTC
This scheduled maintenance affected: Login & Registration (Login, Registration, Email verification, eToro Connect, SMS verification (2FA), Social Media), Payments (Credit cards, PayPal, Wire transfer, More, Withdrawal, Deposit), Trading (Manual trading - Real, Manual trading - Virtual, Automatic execution, CopyTrading), eToro Money (Cash Account, Debit Card, Crypto Wallets, Fast Transfer (Online Banking)), eToro Platform (Watchlist, Portfolio - Real, Portfolio - Virtual, Portfolio - History, Feeds, Discovery, Daily Gain, Charts, Notifications, Account verification, Popular Investors Dashboard, eToro Club Dashboard, Rates, Stop Loss, Take Profit, Tax identification, W8BEN, Interest on balance, live chat, Customer Help portal, Open Customer Service ticket), and APIs, Website, Affiliates portal, Search, Fees, Blockchain Network, Candles.