We apologize for the inconvenience and appreciate your understanding in this matter.
Sincerely, The eToro Team
Posted Sep 15, 2026 - 19:20 UTC
Monitoring
Our provider has implemented a fix, and we are currently monitoring and validating its effectiveness. We will continue to share updates as more information becomes available.
Sincerely, The eToro Team
Posted Sep 15, 2026 - 19:00 UTC
Investigating
We are currently experiencing an issue affecting the authentication of some credit card deposit transactions. The issue is occurring on the side of our third-party service provider.
Our provider is actively investigating the incident, while our team closely monitors the situation and works to restore full functionality as quickly as possible. We understand how frustrating this may be and apologize for any inconvenience.
We will continue to share updates here as more information becomes available.
Sincerely, The eToro Team
Posted Sep 15, 2026 - 18:45 UTC
This incident affected: Payments (Credit cards, Deposit).