Some users may receive great number of notifications from copied accounts
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The great number of notifications from copied accounts issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Jul 20, 2020 - 16:55 UTC
Update
Our devs have identified the root cause and working on a solution.
Posted Jul 20, 2020 - 12:25 UTC
Identified
We've managed to mitigate the impact by disabling the notification distribution from the relevant account.
We are working to resolve the issue and will update ASAP
Posted Jul 20, 2020 - 06:24 UTC
Investigating
We are experiencing a temporary issue with our Push notifications feature. We apologize for the inconvenience and appreciate your patience as we work on resolving it.
Posted Jul 20, 2020 - 05:14 UTC
This incident affected: eToro Platform (Notifications).