Crypto Trading actions and Deposit with CreditCard are partially unavailable
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Feb 28, 2021 - 18:40 UTC
Investigating
We are experiencing a temporary issue with our Trading actions (Trade, Buy, Sell) and Deposit.
We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible
Posted Feb 28, 2021 - 18:27 UTC
This incident affected: Payments (Credit cards) and Trading (Manual trading - Real).