We are pleased to inform you that the scheduled network upgrade ("Plomin") for Cardano ($ADA) has been successfully completed.
Posted Jan 29, 2025 - 22:22 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 29, 2025 - 20:45 UTC
Scheduled
Dear eToro Customers and Partners,
Please note that Cardano $ADA will undergo a scheduled network upgrade (“Plomin”), expected to take place on January 29, 2025 at 21:45 UTC.
The upgrade will commence immediately at the beginning of Epoch #537 and should last for a short period.
Accessing and trading of Cardano $ADA is not expected to be affected unless we deem the upgraded network unstable. If this occurs, $ADA trading will be disabled until the network stabilizes. Coin transfers of Cardano ($ADA) will be halted one hour prior to the fork and for the fork duration.
The Wallet Send function will also not be available, from one hour prior to the fork and for the duration.