Deposit may not be applicable for US clients
Incident Report for eToro
Resolved
The issue has been resolved.
Posted Nov 21, 2019 - 15:20 GMT
Investigating
We are experiencing technical difficulties preventing US users to deposit. This is currently being investigated by relevant key members.
Posted Nov 21, 2019 - 12:08 GMT
This incident affected: Payments (More).