Users may experience issues in opening/closing positions.
Incident Report for eToro
Resolved
The incident has been resolved.
Functionality has been fully restored.
We apologize for the inconvenience.
Posted 5 months ago. May 21, 2019 - 18:26 BST
Monitoring
eToro platform and Wallet App is now available.
We will keep monitoring.
Posted 5 months ago. May 21, 2019 - 16:58 BST
Update
We identified what causing the trading issue and we're working to fix it.
Wallet application is still not available.
Please bear with us while we work on resolving the issue and stay tuned for further updates.
Posted 5 months ago. May 21, 2019 - 16:23 BST
Update
We are experiencing temporary technical difficulties in Wallet application log-in.
Please bear with us while we work on resolving the issue and stay tuned for further updates.
We apologize for the inconvenience.
Posted 5 months ago. May 21, 2019 - 16:05 BST
Update
You can use our offline tool where you can update and open positions.
Please visit https://offlinemode.etoro.com/
Posted 5 months ago. May 21, 2019 - 15:46 BST
Update
We are continuing to investigate this issue.
Please bear with us while we work on resolving the issue and stay tuned for further updates.
Posted 5 months ago. May 21, 2019 - 15:16 BST
Investigating
We are experiencing temporary technical difficulties.
Please bear with us while we work on resolving the issue and stay tuned for further updates.
We apologize for the inconvenience.
Posted 5 months ago. May 21, 2019 - 15:00 BST
This incident affected: Trading (Manual Trading) and Wallet.