Some users may experience login issues to Wallet Application
Incident Report for eToro
Resolved
The issue resolved.
We apologize for the inconvenience
Posted 3 months ago. Jun 24, 2019 - 13:00 BST
Identified
We are experiencing temporary technical difficulties due to third-party issues.
Stay tuned for further updates. We apologize for the inconvenience.
Posted 3 months ago. Jun 24, 2019 - 12:12 BST
This incident affected: Wallet.