Login to eToro platform from China may be unavailable
Incident Report for eToro
Resolved
The incident has been resolved.
We apologize for the inconvenience.
Posted 3 months ago. Aug 01, 2019 - 09:52 BST
Update
eToro's network teams are currently assessing the situation thoroughly in order to alleviate the issue. Apologies for the inconvenience and further details will be promptly updated.
Posted 3 months ago. Jul 31, 2019 - 15:41 BST
Update
We are continuing to investigate this issue.
Posted 3 months ago. Jul 30, 2019 - 13:36 BST
Investigating
We are experiencing temporary technical difficulties. Please bear with us while we work on resolving the issue and stay tuned for further updates. We apologize for the inconvenience.
Posted 3 months ago. Jul 30, 2019 - 11:03 BST
This incident affected: Apps (Login).