Technical issues with eToro platform
Incident Report for eToro
Resolved
We are keep monitoring this issue for the next 24 hours to ensure it is addressed for all customers and resolved completely.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Jun 08, 2020 - 17:07 UTC
Update
We are continuing to monitor for any further issues.
Posted Jun 08, 2020 - 14:13 UTC
Monitoring
We've found the root cause for the issue and solved it. We will monitor this issue for the next 24 hours to ensure it is addressed for all customers and resolved completely. We will provide more updates here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Jun 08, 2020 - 14:13 UTC
Identified
We're currently experiencing technical issues with eToro platform.
We will provide more updates here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Jun 08, 2020 - 13:59 UTC