Login to eToro platform from China may be unavailable
Incident Report for eToro
Resolved
The incident has been resolved.
We apologize for the inconvenience.
Posted 23 days ago. Jul 29, 2019 - 17:44 BST
Update
We are continuing to investigate the issue.
Posted 23 days ago. Jul 29, 2019 - 12:16 BST
Investigating
We are experiencing temporary technical difficulties. Please bear with us while we work on resolving the issue and stay tuned for further updates. We apologize for the inconvenience.
Posted 23 days ago. Jul 29, 2019 - 08:56 BST
This incident affected: Apps (Login).