Empty portfolio/watchlist display issue
Incident Report for eToro
Resolved
The incident has been resolved.
Posted 2 months ago. Apr 12, 2019 - 06:52 BST
Investigating
We are currently experiencing a technical issue which causes some users' portfolios and watchlists to appear as empty. We would like to clarify that this is only a display issue and that the funds/investments have not disappeared.
We are working to resolve this as quickly as possible.
We apologize for any inconvenience this may cause.
Posted 2 months ago. Apr 12, 2019 - 05:43 BST
This incident affected: Apps (Watchlist, Portfolio).