credit cards processing service degradation
Incident Report for eToro
Resolved
This incident has been resolved.
Posted Jul 20, 2020 - 03:33 BST
Investigating
We are experiencing a temporary issue with our credit cards deposit service. We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible
Posted Jul 20, 2020 - 03:28 BST
This incident affected: Payments (Deposit).