Deposits via Wire Transfer are temporary unavailable
Incident Report for eToro
Resolved
The maintenance is done.
Deposits via Wire Transfer is now available.
Posted 4 months ago. Jun 10, 2019 - 17:07 BST
Update
Maintenance is still in progress.
Please stay tuned for further updates.
We apologize for the inconvenience.
Posted 4 months ago. Jun 10, 2019 - 16:25 BST
Identified
Deposits via Wire Transfer are temporarily unavailable due to maintenance work.
Please stay tuned for further updates.
We apologize for the inconvenience.
Posted 4 months ago. Jun 10, 2019 - 13:30 BST
This incident affected: Payments (Wire Transfer).