Some users might experience failures depositing with ACH
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted May 25, 2022 - 16:28 UTC
Identified
We are following the status of the third party vendor, and will provide additional information as soon as we have it.
We appreciate your understanding and apologies for the inconvenience.

Sincerely,
The eToro Team
Posted May 25, 2022 - 16:05 UTC
This incident affected: Payments (Deposit).