Clients from East Asia may experience connectivity issue in the trading flow
Incident Report for eToro
Resolved
Issue has been resolved
Posted Apr 22, 2020 - 17:33 BST
Identified
We are experiencing a temporary issue with our Trading flow (Instrument information, executing trading actions, etc). We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible
Posted Apr 22, 2020 - 14:16 BST
This incident affected: Trading (Manual Trading, Copy Trading).