Customers from Italy may experience login failures
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Jun 17, 2021 - 22:00 UTC
Identified
The root cause of the issue has been identified and we are working with our 3rd party provider to mitigate the issue.
Additional information will be provided as soon as possible.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Jun 17, 2021 - 15:12 UTC
This incident affected: Login & Registration (Login).