We've restored all affected services, and the customer impact has been mitigated.
Deposits, withdrawals, and the ability to open new positions are now functioning normally. Our team will continue to closely monitor the platform to ensure everything remains stable.
We sincerely apologize for the disruption and thank you for your patience and understanding throughout this incident.
Sincerely, The eToro Team
Posted Jun 28, 2026 - 17:12 UTC
Identified
We've identified the cause of the issue affecting deposits, withdrawals, and the ability to open new positions.
Our team is now working on implementing a fix and restoring full service as quickly as possible. Closing existing positions continues to function normally.
We understand how important these services are, and we sincerely appreciate your patience while we resolve this issue. We'll continue to keep you updated on our progress.
Sincerely, The eToro Team
Posted Jun 28, 2026 - 16:08 UTC
Update
We are currently experiencing an issue affecting deposits, withdrawals, and the ability to open new positions.
Some users may be unable to complete deposits or withdrawals, and opening new positions is currently unavailable for affected users. Closing existing positions continues to function as normal.
Our team is actively investigating the issue and working to restore full functionality as quickly as possible.
We understand how disruptive this may be, and we sincerely apologize for the inconvenience. We'll continue to keep you updated on our progress here.
Sincerely, The eToro Team
Posted Jun 28, 2026 - 13:31 UTC
Investigating
We are currently experiencing an issue affecting deposits and withdrawals.
Some users may be unable to complete deposits or withdrawals, or may experience delays while these transactions are being processed.
Our team is actively investigating the issue and working to restore full functionality as quickly as possible.
We understand how frustrating this may be, especially if you're waiting to fund your account or withdraw your funds, and we sincerely apologize for the inconvenience. We'll continue to keep you updated on our progress here.
Sincerely, The eToro Team
Posted Jun 28, 2026 - 13:20 UTC
This incident affected: Trading (Manual trading - Real) and Payments (Withdrawal, Deposit).