Technical issue with open position
Incident Report for eToro
Resolved
We are pleased to inform you that the problem that caused the open position action to be temporarily unavailable has been resolved. We will monitoring this issue for the next 24 hours to ensure it is addressed for all customers and resolved completely.
We appreciate your understanding and apologize for the inconvenience.


Sincerely,
The eToro Team
Posted Jun 11, 2020 - 17:30 BST
Monitoring
We've found the root cause for the issue and solved it. We will monitor this issue for the next 24 hours to ensure it is addressed for all customers and resolved completely. We will provide more updates here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Jun 11, 2020 - 16:51 BST
Identified
Please be aware that we have identified the reason for the issue.
During this time you may experience issues with opening positions.
We are continuing to investigate this issue. You will be notified once it is resolved.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Jun 11, 2020 - 16:45 BST
This incident affected: Trading (Manual trading - Real).