No virtual equity for new registers in demo account
Incident Report for eToro
Resolved
We've found the root cause for the issue and solved it. We will monitor this issue for the next 24 hours to ensure it is addressed for all customers and resolved completely. We will provide more updates here. Apologise for the interruption.
Posted May 17, 2020 - 10:38 BST
Update
We are continuing to investigate this issue.
Posted May 17, 2020 - 07:52 BST
Investigating
We are experiencing a temporary issue with virtual equity for new registers in demo account. We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible
Posted May 17, 2020 - 07:39 BST
This incident affected: Virtual Equity.