The incident has been resolved. We apologize for the inconvenience and appreciate your understanding in this matter.
Sincerely, The eToro Team
Posted Sep 16, 2026 - 16:10 UTC
Investigating
We are currently experiencing an issue related to a third-party service provider affecting several customer support contact channels. Some Customers are unable to contact eToro via chat, cases, chatbot, or WhatsApp.
Our provider is actively investigating the incident and our team is closely monitoring the situation, but there is currently no estimated time for resolution or known workaround.
Club customers may continue to contact their account manager directly by email. We apologize for any inconvenience and will provide further updates as more information becomes available.
Posted Sep 16, 2026 - 12:32 UTC
This incident affected: eToro Platform (live chat, Customer Help portal, Open Customer Service ticket).