iDeal Bank Page Issue
Incident Report for eToro
Resolved
We are pleased to inform you that the problem that caused the processing payments via iDeal to be temporarily unavailable has been resolved.

We appreciate your understanding and apologise for the inconvenience.


Sincerely,
The eToro Team
Posted Jun 23, 2020 - 15:40 BST
Update
A fix was implemented and solved the issue for Android version.
We are continuing to work on a fix for iOS version.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Jun 22, 2020 - 09:18 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 11, 2020 - 09:43 BST
Update
We are continuing to investigate this issue.
Posted Jun 11, 2020 - 09:20 BST
Investigating
We are experiencing a temporary issue with processing payments via iDeal has a degraded service for mobiles. We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible
Posted Jun 11, 2020 - 09:17 BST
This incident affected: Payments (More).