The issue affecting some pages in the iOS app has been resolved.
A hotfix was deployed, and our QA team has verified that it successfully restored functionality for the affected pages, including the Deposit, Registration, and News pages.
We apologize for any inconvenience this may have caused and appreciate your patience while we worked to resolve the issue.
Sincerely, The eToro Team
Posted Jun 20, 2026 - 05:16 UTC
Investigating
We are currently experiencing an issue affecting some pages on iOS devices. Some users using the iOS app may be unable to load:
* The deposit page * The registration page * News pages
As a workaround, you can visit www.etoro.com from a desktop browser or mobile browser to access these services.
Our team is actively investigating the issue and working to resolve it as quickly as possible. We understand how important this is and sincerely apologize for the inconvenience. We’ll continue to keep you updated on our progress here. Sincerely, The eToro team
Posted Jun 19, 2026 - 17:45 UTC
This incident affected: Login & Registration (Registration) and Payments (Deposit).