Users may experience trading issues
Incident Report for eToro
Resolved
The incident has been resolved.
Functionality has been fully restored.
We apologize for the inconvenience.
Posted 3 months ago. Feb 19, 2019 - 13:17 GMT
Monitoring
We experienced temporary technical difficulties that affected several users in trading actions.
All systems are now up.
We will keep monitoring the system to ensure full functionality.
We apologize for the inconvenience.
Posted 3 months ago. Feb 19, 2019 - 12:54 GMT
This incident affected: Trading (Manual Trading).