Login to Wallet Platform is unavailable
Incident Report for eToro
Resolved
Login is now available and Wallet platform is fully functional.
Posted Dec 08, 2019 - 20:14 GMT
Identified
Wallet platform is currently under maintenance. Login will shortly be available once maintenance has been completed. Please be kept updated and apologies for any inconvenience.
Posted Dec 08, 2019 - 18:41 GMT
This incident affected: Wallet.