Incorrect display on China Union Pay Cashout cashier in simplified Chinese
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,

The Incorrect display on China Union Pay Cashout cashier in simplified Chinese issue has been resolved.
We apologize for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Jul 17, 2020 - 18:04 BST
Identified
The root cause of the issue has been identified and our developers are working to fix it. The field for bank account number is wrongly translated as "bank name". Traditional Chinese and English are showing correctly (screenshots below).
Additional information will be provided as soon as possible.
We appreciate your understanding and apologise for the inconvenience.


Sincerely,
The eToro Team
Posted Jul 17, 2020 - 16:08 BST
This incident affected: Payments (More).