Login is partially unavailable
Incident Report for eToro
Resolved
We've found the root cause for the issue and solved it. We will monitor this issue for the next 24 hours to ensure it is addressed for all customers and resolved completely. We will provide more updates here. Apologize for the interruption.
Posted May 19, 2020 - 18:16 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 18, 2020 - 17:08 BST
Identified
We're currently having a partial issue with login service. We're apologizing for the inconvenience and we're working on solution.
Posted May 18, 2020 - 17:00 BST
This incident affected: Apps (Login).