Trading actions are partially unavailable
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The trading actions issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Jul 08, 2020 - 18:57 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 08, 2020 - 18:44 BST
Investigating
Please note that we currently have technical issues with one of eToro’s services. Our team is working hard to resolve the issue. We appreciate your understanding and apologise for the inconvenience. Sincerely, The eToro Team
Posted Jul 08, 2020 - 18:22 BST
This incident affected: Trading (Manual trading - Real).