Deposit via Credit Cards issue
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Oct 13, 2020 - 07:08 UTC
Update
We are continuing to work on a fix for this issue.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Oct 13, 2020 - 06:31 UTC
Update
We are continuing to work on a fix for this issue.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Oct 13, 2020 - 05:43 UTC
Update
We are continuing to work on a fix for this issue.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Oct 13, 2020 - 04:41 UTC
Identified
We have identified the root cause and our developers are working to fix it.
Additional information will be provided as soon as possible.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Oct 13, 2020 - 01:08 UTC
Investigating
Please note that we currently have technical issues depositing with Credit Card method on the platform.
Our team is working hard to resolve the issue.
Please use a different deposit method until the issue resolved
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Oct 12, 2020 - 22:46 UTC
This incident affected: Payments (Credit cards).