Users may experience deposits issues via PayPal
Incident Report for eToro
Resolved
Deposits via PayPal are now working properly.
We apologize for the inconvenience.
Posted 3 months ago. May 23, 2019 - 11:53 BST
Identified
We are experiencing a temporary issue with deposits via PayPal.
We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible
Posted 3 months ago. May 23, 2019 - 06:45 BST
This incident affected: Payments (PayPal).