Login to the platform is unavailable
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Feb 24, 2021 - 08:55 UTC
Update
All services are up and running.
We will continue to monitor our services closely.


Sincerely,
The eToro Team
Posted Feb 24, 2021 - 08:30 UTC
Monitoring
We have implemented a solution to resolve the issue, and will monitor it for the next hours to make sure it is successfully resolved.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Feb 24, 2021 - 08:06 UTC
Update
Teams are still working to resolved the incident.
Please note that you can use our Offline Trader Tool. This can be accessed when you try and log into the platform. Alternatively it can be accessed at https://offlinemode.etoro.com.

You can use this tool to view all open positions and to close open trades.
Once again, we apologise for the inconvenience and thank you for your patience as we do everything we can to resolve this issue as quickly as possible.

Sincerely,
The eToro Team
Posted Feb 24, 2021 - 07:51 UTC
Update
Teams are still working to resolved the incident.
Please note that you can use our Offline Trader Tool. This can be accessed when you try and log into the platform. Alternatively it can be accessed at https://offlinemode.etoro.com.

You can use this tool to view all open positions and to close open trades.
Once again, we apologise for the inconvenience and thank you for your patience as we do everything we can to resolve this issue as quickly as possible.

Sincerely,
The eToro Team
Posted Feb 24, 2021 - 07:30 UTC
Update
Teams are still working to resolved the incident.
Please note that you can use our Offline Trader Tool. This can be accessed when you try and log into the platform. Alternatively it can be accessed at https://offlinemode.etoro.com.

You can use this tool to view all open positions and to close open trades.
Once again, we apologise for the inconvenience and thank you for your patience as we do everything we can to resolve this issue as quickly as possible.

Sincerely,
The eToro Team
Posted Feb 24, 2021 - 07:11 UTC
Update
Teams are still working to resolved the incident.
Please note that you can use our Offline Trader Tool. This can be accessed when you try and log into the platform. Alternatively it can be accessed at https://offlinemode.etoro.com.

You can use this tool to view all open positions and to close open trades.
Once again, we apologise for the inconvenience and thank you for your patience as we do everything we can to resolve this issue as quickly as possible.

Sincerely,
The eToro Team
Posted Feb 24, 2021 - 06:28 UTC
Update
Teams are still working to resolved the incident.
Please note that you can use our Offline Trader Tool. This can be accessed when you try and log into the platform. Alternatively it can be accessed at https://offlinemode.etoro.com.

You can use this tool to view all open positions and to close open trades.
Once again, we apologise for the inconvenience and thank you for your patience as we do everything we can to resolve this issue as quickly as possible.

Sincerely,
The eToro Team
Posted Feb 24, 2021 - 05:40 UTC
Update
Teams are still working to resolved the incident.
Please note that you can use our Offline Trader Tool. This can be accessed when you try and log into the platform. Alternatively it can be accessed at https://offlinemode.etoro.com.

You can use this tool to view all open positions and to close open trades.
Once again, we apologise for the inconvenience and thank you for your patience as we do everything we can to resolve this issue as quickly as possible.

Sincerely,
The eToro Team
Posted Feb 24, 2021 - 04:23 UTC
Update
Teams are still working to resolved the incident.
Please note that you can use our Offline Trader Tool. This can be accessed when you try and log into the platform. Alternatively it can be accessed at https://offlinemode.etoro.com.

You can use this tool to view all open positions and to close open trades.
Once again, we apologise for the inconvenience and thank you for your patience as we do everything we can to resolve this issue as quickly as possible.

Sincerely,
The eToro Team
Posted Feb 24, 2021 - 03:11 UTC
Update
Teams are still working with Microsoft engineers to resolved the incident.
Please note that you can use our Offline Trader Tool. This can be accessed when you try and log into the platform. Alternatively it can be accessed at https://offlinemode.etoro.com.

You can use this tool to view all open positions and to close open trades.
Once again, we apologise for the inconvenience and thank you for your patience as we do everything we can to resolve this issue as quickly as possible.

Sincerely,
The eToro Team
Posted Feb 24, 2021 - 02:13 UTC
Update
Teams are still working with Microsoft engineers to resolved the incident.
Please note that you can use our Offline Trader Tool. This can be accessed when you try and log into the platform. Alternatively it can be accessed at https://offlinemode.etoro.com.

You can use this tool to view all open positions and to close open trades.
Once again, we apologise for the inconvenience and thank you for your patience as we do everything we can to resolve this issue as quickly as possible.

Sincerely,
The eToro Team
Posted Feb 24, 2021 - 01:16 UTC
Update
We sincerely apologise for the service disruptions on our platform. We are working with senior teams at Microsoft to resolve this issue as quickly as we can.
Please note that you can use our Offline Trader Tool. This can be accessed when you try and log into the platform. Alternatively it can be accessed at https://offlinemode.etoro.com.

You can use this tool to view all open positions and to close open trades.
Once again, we apologise for the inconvenience and thank you for your patience as we do everything we can to resolve this issue as quickly as possible.

Sincerely,
The eToro Team
Posted Feb 23, 2021 - 20:46 UTC
Update
We are continuing to work on a fix for this issue.
Posted Feb 23, 2021 - 20:09 UTC
Update
We are continuing to work on a fix for this issue.
Posted Feb 23, 2021 - 18:56 UTC
Update
We are continuing to work on a fix for this issue.
Posted Feb 23, 2021 - 17:58 UTC
Update
We have enabled our Offline Trading tool to provide a way to close your position in case the platform is unresponsive.
Please visit https://offlinemode.etoro.com/ to close your open position.
Posted Feb 23, 2021 - 17:56 UTC
Update
We are continuing to work on a fix for this issue.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Feb 23, 2021 - 17:34 UTC
Update
We are continuing to work on a fix for this issue.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Feb 23, 2021 - 17:11 UTC
Update
We are continuing to work on a fix for this issue.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Feb 23, 2021 - 16:51 UTC
Update
We are continuing to work on a fix for this issue.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Feb 23, 2021 - 16:37 UTC
Update
We are continuing to work on a fix for this issue.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Feb 23, 2021 - 16:17 UTC
Update
We are continuing to work on a fix for this issue.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Feb 23, 2021 - 15:32 UTC
Identified
The root cause of the issue has been identified and our developers are working to fix it.
Additional information will be provided as soon as possible.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Feb 23, 2021 - 15:14 UTC
This incident affected: Login & Registration (Login, Registration, Email verification, eToro Connect), Payments (Credit cards, PayPal, Wire transfer, More, Withdrawal, Deposit), Trading (Manual trading - Real, Manual trading - Virtual, Automatic execution, CopyTrading), Platform (Watchlist, Portfolio - Real, Portfolio - Virtual, Portfolio - History, Feeds, Discovery, Stats, Charts, Notifications, Account verification), and Wallet.