Login is partially unavailable from some of the Asia states
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Jun 16, 2021 - 22:02 UTC
Update
Our 3rd party provider has identified the issue and the root cause. They are working to implement a fix for it.
We will provide more updates as we have them.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Jun 16, 2021 - 21:38 UTC
Update
We are working with our 3rd party provider to identify the root cause and mitigate the issue.

Additional information will be provided as soon as possible.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Jun 16, 2021 - 20:49 UTC
Update
We are working with our 3rd party provider to identify the root cause and mitigate the issue.

Additional information will be provided as soon as possible.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Jun 16, 2021 - 20:17 UTC
Update
We continue to investigate this issue.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Jun 16, 2021 - 19:08 UTC
Identified
The root cause of the issue has been identified and our developers are working to fix it.
Additional information will be provided as soon as possible.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Jun 16, 2021 - 18:56 UTC
This incident affected: Login & Registration (Login).