Login to eToro platform from China may be unavailable
Incident Report for eToro
Resolved
The incident has been resolved.
We apologize for the inconvenience.
Posted 10 days ago. Sep 11, 2019 - 13:23 BST
Monitoring
Services to eToro's platform from China has returned as usual. We are currently monitoring the issue to ensure stability to our services.
Posted 10 days ago. Sep 11, 2019 - 12:13 BST
Investigating
We are experiencing temporary technical difficulties. Please bear with us while we work on resolving the issue and stay tuned for further updates. We apologize for the inconvenience.
Posted 10 days ago. Sep 11, 2019 - 11:46 BST
This incident affected: Apps (Login).