Charts are unavailable in WatchList
Incident Report for eToro
Resolved
Watchlist charts are now loading properly.
We apologize for the inconvenience.
Posted 5 months ago. Oct 28, 2018 - 11:45 GMT
Investigating
We are experiencing a temporary issue with the watchlist charts. We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible.
Posted 5 months ago. Oct 28, 2018 - 11:40 GMT
This incident affected: Apps (Watchlist).