Some payment methods are failing to process deposits
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted May 20, 2021 - 15:06 UTC
Identified
Hello,

Zotapay, Trustly, Ideal, Ecommpay, and Poli payment methods may fail to process deposits. If you encounter an issue with the listed (or other) payment methods, please try a different payment method.

The root cause of the issue has been identified and our developers are working to fix it.
Additional information will be provided as soon as possible.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted May 20, 2021 - 13:35 UTC
This incident affected: Payments (Deposit).