Wallet is currently unavailable
Incident Report for eToro
Resolved
This incident has been resolved.
We're apologizing for the inconvenience.
Posted Apr 19, 2020 - 18:00 BST
Identified
We're currently having a technical issue with Wallet service.
We're apologizing for the inconvenience.
Posted Apr 19, 2020 - 16:05 BST
This incident affected: Wallet.