We apologize for the inconvenience and appreciate your understanding in this matter.
Sincerely, The eToro Team
Posted Feb 24, 2026 - 06:29 UTC
Update
Hello,
We are aware of an issue affecting some users where individual stocks may not appear in the Watchlist. Trading capabilities are not impacted.
Our teams are continuing to investigate and are working to resolve the issue as soon as possible.
We apologize for the inconvenience and will provide further updates as more information becomes available.
Sincerely, The eToro Team
Posted Feb 23, 2026 - 14:52 UTC
Update
Hello,
We are currently investigating an issue where individual stocks are not appearing in the Watchlist for some users. Our team is actively working to determine the root cause and restore full functionality.
We apologize for the inconvenience and appreciate your patience. Further updates will be shared here as they become available.
Sincerely, The eToro Team
Posted Feb 23, 2026 - 06:42 UTC
Investigating
We are currently investigating an issue where some users may be unable to see individual stocks in their Watchlist. Trading functionality is not impacted.
Our team is actively investigating and working to restore full functionality as soon as possible.
We apologize for the inconvenience and appreciate your patience. Updates will be shared here as they become available.
Sincerely, The eToro team
Posted Feb 22, 2026 - 19:48 UTC
This incident affected: eToro Platform (Watchlist).