Login to the wallet problem
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Nov 30, 2020 - 15:47 UTC
Update
We are continuing to work on a fix for this issue.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Nov 30, 2020 - 15:28 UTC
Identified
The root cause of the issue has been identified and our developers are working to fix it.
Some of the customers may experience an issue with login to the wallet
Additional information will be provided as soon as possible.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Nov 30, 2020 - 15:09 UTC
This incident affected: Wallet.