New clients may experience an issue to deposit funds using credit card
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The "new clients may experience an issue to deposit funds using a credit card" issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Jul 09, 2020 - 17:47 BST
Identified
The root cause of the issue has been identified and our developers are working to fix it.
Additional information will be provided as soon as possible.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Jul 09, 2020 - 13:07 BST
Investigating
Please note that we currently new clients may experience an issue to deposit funds using credit card.
Our team is working hard to resolve the issue.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Jul 09, 2020 - 13:03 BST
This incident affected: Payments (Deposit).