Stats not loading
Incident Report for eToro
Resolved
Stats is now loading properly.
We apologize for the inconvenience.
Posted 10 months ago. Sep 17, 2018 - 07:24 BST
Investigating
We are experiencing a temporary issue with the stats. We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible.
Posted 10 months ago. Sep 17, 2018 - 06:40 BST
This incident affected: Apps (Stats).