Clients in Vietnam may experience issues with verifying their phone
Incident Report for eToro
Resolved
The incident has been resolved.
We apologize for the inconvenience.
Posted Dec 02, 2019 - 05:56 UTC
Identified
The issue has been identified to be related to network problems in the region
Posted Nov 29, 2019 - 13:55 UTC