Sign up for eToro Practice Account is temporary unavailable.
Incident Report for eToro
Resolved
This incident was resolved.
To practice on eToro platform please visit: https://go.etoro.com/en/practice-account
Posted Apr 22, 2020 - 14:00 BST
Identified
We've found the root cause for the issue and working to solve it. Apologise for the interruption.
Posted Apr 22, 2020 - 13:26 BST
Investigating
Sign up for eToro Practice Account is temporary unavailable, we are investigating the issue.
Posted Apr 22, 2020 - 12:52 BST
This incident affected: Sign up page.