Open eToro iOS app issue
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The open eToro iOS app issue has been resolved on Apple's side.

We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Jul 10, 2020 - 15:47 BST
Investigating
Please note that there is a technical issue with opening eToro app in iOS due to a worldwide issue on Apple's side.
Please use the eToro website platform.

More updates will be provided here.

We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Jul 10, 2020 - 13:07 BST
This incident affected: Login & Registration (eToro Connect).