Possible issue for US new users during know your customers process
Incident Report for eToro
Resolved
This incident has been resolved.
Posted Jun 13, 2020 - 00:22 BST
Investigating
We are experiencing a temporary issue for US new users during know your customers process, We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible
Posted Jun 12, 2020 - 20:31 BST